読者です 読者をやめる 読者になる 読者になる

三項演算子なんていわないよ絶対

misc

C++のソースをなおしながら、Pythonの構文チェッカをつくっていたので、

motion_id = default_motion ? default_motion != -1 : MOTION_WAIT

みたいな書き方をしてしまった。
いや、Pythonのせいじゃないんだけどね……。

motion_id = default_motion if default_motion != -1 else MOTION_WAIT

は最初みたとき違和感があったけど、
こっちの方が自然だなぁ、とか思い始めた。